UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - Cisco 基本コマンド




Ciscoルータ、Catalystスイッチにおいて設定作業を行う際には基本的にCLI ( コンソールやtelnet ) のコマンドを用います。一部でGUIから設定を行うツールなども存在しますが、かゆい部分にまで手が届かないということもあるので奨励はいたしません。


CLIで設定やメッセージの表示を行う際には複数のモードが用意されており、表示したい内容・設定したい内容にあわせてモードを切り替えていく必要があります。このモードは階層化されておりコマンド入力によってモード間を移動することができます。

これら複数のモードを図で表すと以下のようになります。




■Ciscoルータにおける各モード

Ciscoルータには主に以下のモードがあります。


■User EXECモード 設定の参照が出来るモード
■Privileged EXECモード 参照だけでなく各種設定が出来るモード
■Global Configurationモード ルータ全体の設定を行うためのモード
■Interface Configurationモード インターフェイス毎の設定を行うためのモード
■Line Configurationモード telnetおよびコンソールの設定を行うためのモード
■ROM Monitorモード IOS起動前のサブセットIOS。これが起動してからIOS本体を起動するというプロセスになります。パスワードリカバリやIOSが見つからない場合にこのモードになります。

cisco> User EXECモードをあらわすプロンプト
cisco> enable Privileged EXECモードへの移行
Password: パスワードの入力
cisco# Privileged EXECモードをあらわすプロンプト
cisco# configure terminal グローバルコンフィグモードへの移行
cisco(config)# グローバルコンフィグモードをあらわすプロンプト
cisco(config-router)# その他のコンフィグモード
cisco(config-router)# exit グローバルコンフィグモードへの移行
cisco(config)# exit Privileged EXECモードへの移行
cisco# disable User EXECモードへの移行


各モードを終了し特権EXECモードに戻るにはendを入力します。


■Ciscoルータにおける基本コマンド

cisco# erase startup-config 起動時設定ファイルの削除(初期化)
cisco# reload 再起動
cisco# copy running-config startup-config 設定保存
cisco# show interface serial 0/0 インターフェイスの状態確認
cisco# show running-config アクティブな設定情報を表示
cisco# show startup-config 起動時設定情報を表示
cisco# show ip route ルーティングテーブルの表示


■CiscoルータにおけるIPアドレスの設定

インターフェイスへのIPアドレスの設定は設定したいインターフェイスモードで以下のコマンドを実行します。

・FastEthernetインターフェイスにIPアドレスを設定します。


cisco> enable
Password: xxxxx
cisco# configure terminal
cisco(config)# interface fastethernet 0/0
cisco(config-if)# ip address 192.168.5.10 255.255.255.0
cisco(config-if)# no shutdown(すぐ有効にならないのでシャットダウン解除)
cisco(config-if)# exit


・FastEthernetインターフェイスにサブインターフェイスを作成しIPアドレスを設定します。


cisco> enable 
Password: xxxxx
cisco# configure terminal
cisco(config)# interface fastethernet 0/0.1
cisco(config-subif)# ip address 192.168.5.11 255.255.255.0
cisco(config-subif)# no shutdown(すぐ有効にならないのでシャットダウン解除)
cisco(config-subif)# exit


・SerialインターフェイスにIPアドレスを設定します。


cisco(config)# interface serial 0/0
cisco(config-if)# ip address 192.168.5.20 255.255.255.0
cisco(config-if)# no shutdown
cisco(config-if)# exit


・インターフェイスにコメントをつけます


(config)# int fa0/0
(config-if)# description To:LAN 


■Ciscoルータにおけるスタティックルートの追加

スタティックルートの追加はまず下記コマンドでルーティングをオンにします。


cisco# configure terminal
cisco(config)# ip routing


・スタティックルートを追加します。


cisco(config)# ip route 192.16.4.0 255.255.255.0 192.16.4.20
cisco(config)# ip route 192.16.5.0 255.255.255.0 192.16.5.10
cisco(config)# exit
cisco#show ip route


送信先へのルートが不明な場合に使用される特別経路情報をデフォルトルートと言います。デフォルトルートを利用するとIPアドレス、サブネットマスクともに0.0.0.0を使用します。


cisco# configure terminal
cisco(config)# ip route 0.0.0.0 0.0.0.0 192.16.4.20
cisco(config)# exit


またCiscoルータでは通常コマンドにnoをつけることによって設定を解除できます。

cisco# configure terminal
cisco(config)# no ip route 192.16.4.0 255.255.255.0 192.16.4.20
cisco(config)# no ip route 192.16.5.0 255.255.255.0 192.16.5.10
cisco(config)# exit




■少しだけ便利なIOSの小技


○ DNSへの問い合わせ

間違ったスペルでコマンドを入力するとドメイン・サーバに問い合わせにいき、プロンプトがすぐに帰ってこずに苛つくことがよくあります。

# ww
Translating "ww"...domain server (255.255.255.255)

Translating "ww"...domain server (255.255.255.255)
 (255.255.255.255)
Translating "ww"...domain server (255.255.255.255)
% Unknown command or computer name, or unable to find computer address

これはグローバルコンフィグレーションモードで次のコマンドを入力することで回避できます。

(config)# no ip domain-lookup

○ 自動ログアウトしない

コンソール接続またはtelnetなど、仮想端末に接続して操作を行うとき、しばらく操作せずに放っておくとターミナルが自動ログアウトしてしまいます。これを避けるには以下の設定を実施しておきます。

(config)# line con 0
(config-line)# exec-timeout 0 0

○ more表示せずに一気に表示する

sh runなど表示内容が多い場合、IOSでは基本的にターミナル上に1ページづつ表示しスペースキーで次の表示がされるという動きになります。これを1ページずつではなく一気に表示させる設定が以下の設定です。

# terminal length 0

逆に一気に表示させずに1ページずつに戻す場合は次のようになります。

# terminal length 24

○ ログ表示に対して自動改行

コマンドをうっているとログが表示されてコマンド入力するのに非常に邪魔になることがあります。このとき、プロンプトを自動的に改行することが出来るコマンドが以下です。

(config)# line vty 0 4
(config-line)# logging synchronous

○ 時刻自動表示

任意のshowコマンドを打つ度に時刻やCPU負荷率などを自動的に表示するコマンドです。これは個人的には必須なコマンドだと思っています。

(config)# line vty 0 4
(config-line)# exec prompt timestamp


○ グローバルコンフィグレーションモードでshowコマンド

グローバルコンフィグレーションモード以上では基本的に設定を行うモードであり、showコマンドでステータスなどの確認を行うことはできません。但し、doコマンドを用いることでグローバルコンフィグレーションモードでも頭に「do」をつけることでshowコマンドを実行することが可能となります。単純な機能ですがこれは実務で非常に役にたちます。

(config)# do sh runn
Building configuration...

Current configuration : 1249 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
<省略>

○ show techコマンド

Cisco IOSには実に数えきれないぐらいのshowコマンドが用意されていますが、全てではないものの大半のshow コマンドを集約したコマンドがあります。それがshow tech-supportコマンドです。Cisco機器に何らかの障害が発生した場合はこのログを採取して解析することがほとんどで現場では必須のコマンドといえます。

# show tech-support

大量の出力がありますのでTeraTermなどのログ保存機能で保存することをお勧めいたします。


 関連記事
 Ciscoルータの初期設定
 Ciscoルータの基本操作
 パスワードリカバリ
 AAA/RADIUSの設定
 時刻修正
 Syslogの設定
 SPAN / Wiresharkの設定
 SNMPの設定
 PerlでCisco機器を操作
 CiscoIOSのアップグレード
 CiscoIOSのバージョン表記(15系
 Copyright(C) 2003-2013 UnixPower on Networking All rights reserved.