UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - Cisco EIGRP



■EIGRPの設定


次のコマンドでEIGRPを有効にします。


(config)# router eigrp [AS番号]


AS番号は1~65535の間で任意に選択可能ですが、他のEIGRPルータと一致させておく必要があります。


(config)# router eigrp 170
(config-router)# network 192.168.1.0 0.0.0.255
(config-router)# network 192.168.2.0 0.0.0.255


EIGRPに配信したいネットワークを上記コマンドで指定します。エリアの指定がない分を除けばOSPFと同一です。


(config)# router eigrp 170
(config-router)# passive-interface VlanX
(config-router)# passive-interface VlanY


Helloパケットを送出しないインターフェイスをpassive-interfaceで指定できます。EIGRPの隣接関係を結ぶルータがあらかじめないとわかっているなら症例のコマンドです。


(config)# router eigrp 170
(config-router)# no auto-summary


上記コマンドで自動集約を無効とします。


(config)# interface VlanX
(config-if)# bandwidth 100000
(config-if)# delay 10


EIGRPとは直接関係ないのですが、メトリック計算の際に用いられる帯域幅と遅延の値を上記コマンドで変更可能です。delayの単位はmsecです。これらの値はあくまで管理上の値を変更するわけでbandwidthの値を減らしたからといって実際の帯域まで絞られるわけではありません。


(config)# router eigrp 170
(config-router)# eigrp stub [connected | static]


上記は何げに非常に重要なコマンドです。HUB & Spoke型のネットワークを構築している場合、拠点数が非常に多い場合、何かしらの変更があった場合はネットワーク全体が非常に不安定になるというのを身をもって経験しました。自身のルータ配下にEIGRPルータが存在しない場合は代替えルートがないということなのでクエリの送出を停止します。これを設定しておかないとクエリの連鎖反応が頻発しネットワーク不安定という事態に陥ってしまいます。


(config)# router eigrp 170
(config-router)# ip summary eigrp [AS番号] address mask


networkで指定するネットワークが連続して集約できるようであれば個別経路を流すのではなく上のコマンドで一つの経路に集約することが可能です。


■EIGRPの経路再配布/制御


大規模なネットワークになるほど、1つのルーティングプロトコルのみで運用しているところは少ないと思います。EIGRPなどのダイナミックルーティングプロトコルを使用しているところならStaticRoutingは少なからず入り混じってると思います。こういった場合、Static経路をOSPFに再配布する必要があります。



上の構成図のR2とR3では次のように設定しています。


【 R2 】
router eigrp 170
 redistribute static
 network 192.168.0.0
 network 192.168.2.0
 no auto-summary
!
ip forward-protocol nd
ip route 172.16.0.0 255.255.255.0 192.168.2.1
ip route 172.16.1.0 255.255.255.0 192.168.2.1
ip route 172.16.2.0 255.255.255.0 192.168.2.1

【 R3 】
router eigrp 170
 redistribute static
 network 192.168.1.0
 network 192.168.3.0
 no auto-summary
!
ip forward-protocol nd
ip route 172.16.0.0 255.255.255.0 192.168.3.1
ip route 172.16.1.0 255.255.255.0 192.168.3.1
ip route 172.16.2.0 255.255.255.0 192.168.3.1


このとき、R1のルーティングテーブルは以下のようになります。172.16に対する経路は2つ存在し、R2/R3から同条件で再配布しているのでメトリックも全く同一となりバランスされる状態になります。


R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
D EX    172.16.0.0 [170/307200] via 192.168.1.2, 00:00:22, FastEthernet0/1
                   [170/307200] via 192.168.0.2, 00:00:22, FastEthernet0/0
D EX    172.16.1.0 [170/307200] via 192.168.1.2, 00:00:22, FastEthernet0/1
                   [170/307200] via 192.168.0.2, 00:00:22, FastEthernet0/0
D EX    172.16.2.0 [170/307200] via 192.168.1.2, 00:00:22, FastEthernet0/1
                   [170/307200] via 192.168.0.2, 00:00:22, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1
D    192.168.2.0/24 [90/307200] via 192.168.0.2, 00:39:28, FastEthernet0/0
D    192.168.3.0/24 [90/307200] via 192.168.1.2, 00:39:30, FastEthernet0/1


今は3経路とも再配布されていますが、この中の例えば172.16.0.0/24のみ再配布するという制御も可能です。R2とR3にroute-mapを使用した設定を追加します。


【 R2 / R3 】
access-list 10 permit 172.16.0.0 0.0.0.255
route-map red-eigrp permit 10
 match ip address 10

router eigrp 170
 redistribute static route-map red-eigrp

【 R1 】
R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.0.0 [170/307200] via 192.168.1.2, 00:08:37, FastEthernet0/1
                   [170/307200] via 192.168.0.2, 00:08:37, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1
D    192.168.2.0/24 [90/307200] via 192.168.0.2, 00:47:42, FastEthernet0/0
D    192.168.3.0/24 [90/307200] via 192.168.1.2, 00:47:44, FastEthernet0/1


上記ではroute-mapを使って特定の経路を再配布していますが、別な手法としてdistribute-listを使うこともできます。( OSPFでは使用不可 )これはEIGRP経路なのか再配布経路なのかの区別はなくaccess-listで定義した経路のみネイバーに配布するようになります。

【 R2 / R3 】
access-list 10 permit 172.16.0.0 0.0.0.255

router eigrp 170
 distribute-list 10 out FastEthernet0/0

【 R1 】
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.0.0 [170/307200] via 192.168.1.2, 00:19:01, FastEthernet0/1
                   [170/307200] via 192.168.0.2, 00:19:01, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1


OSPFにはできない芸当でEIGRPでは特定経路に対してメトリックを調整することができます。R1に主眼をおいて上の状態からR3経由 (R1のFa0/1経由) で受け取る特定経路 ( 172.16.0.0/24 ) に対してメトリックを加算します。元々、等コストでバランシングされていた状態ですので1でもメトリックを足せば、もう一方の経路のみルーティングテーブルにインストールされます。これにはoffset-listを使用します。


【 R1 】
access-list 10 permit 172.16.0.0 0.0.0.255
router eigrp 170
 offset-list 10 in 1000 FastEthernet0/1

R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.0.0 [170/307200] via 192.168.0.2, 00:00:46, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/1


この設定はR3における次の設定と同様の結果になります。


access-list 10 permit 172.16.0.0 0.0.0.255
router eigrp 170
 offset-list 10 out 1000 FastEthernet0/0




■EIGRPの確認


以下のコマンドでEIGRPの隣接関係を確認できます。


R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 170
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.1.2             Fa0/1             10 01:34:27   32   200  0  24
0   192.168.0.2             Fa0/0             14 01:35:32   30   200  0  27


その他、以下のshowコマンドがあります。


・ネイバーテーブル詳細


R1# show ip eigrp neighbors detail
IP-EIGRP neighbors for process 170
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.1.2             Fa0/1             13 01:35:02   32   200  0  24
   Restart time 00:05:46
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 1
0   192.168.0.2             Fa0/0             11 01:36:07   30   200  0  27
   Restart time 00:24:30
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 1


・トポロジーテーブル確認


R1# show ip eigrp topology
IP-EIGRP Topology Table for AS(170)/ID(192.168.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.0.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/1
P 172.16.0.0/24, 1 successors, FD is 307200
        via 192.168.0.2 (307200/281600), FastEthernet0/0
        via 192.168.1.2 (308200/282600), FastEthernet0/1


・ルーティングプロトコル情報


R1# show ip protocols
Routing Protocol is "eigrp 170"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Incoming routes in FastEthernet0/1 will have 1000 added to metric if on list 10
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 170
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.0.0
    192.168.1.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.2           90      00:06:41
    192.168.1.2           90      00:06:41
  Distance: internal 90 external 170


・EIGRPに参加しているインターフェイス情報


R1# show ip eigrp interfaces
IP-EIGRP interfaces for process 170
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              1        0/0        30       0/2          120           0
Fa0/1              1        0/0        32       0/2          132           0



 
 関連記事
 EIGRPの概要
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.