UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - IPv6のルーティング(EIGRPv6)設定




■IPv6ルーティング

IPv6のルーティングに関してIPv4と比較して大きな変化はありません。IPv4でルーティングプロトコルを設計・運用していたかたなら、そこで培ったノウハウをIPv6でもすぐに発揮することができます。個々のIPv6ルーティングについても各々のコンセプトは従来のIPv4にIPv6拡張機能を追加したという意味合いが強くルーティングアルゴリズムに大きな変更が加えられたものではありません。

以下がIPv4とIPv6のルーティングプロトコルの対応表です。

名称  IPv4  IPv6 
Static Routing
Default Route  ○  ○ 
Unicast IGP
RIP  RIPv1  × 
  RIPv2  RIPng 
OSPF OSPFv2  OSPFv3 
IGRP  IGRP  × 
EIGRP  EIGRP  EIGRPv6 
ISIS ISIS  ISISv6 
Unicast EGP
BGP  BGP  MP-BGP ( BGP4+ )
Multicast
PIM  PIM  PIM 


ルーティングプロトコルでやりとりをするアドレスはリンクローカルアドレスでした。スタティックルーティングにおいてネクストホップアドレスを指定する際はグローバルユニキャストアドレスではなくリンクローカルアドレスを指定することになります。例えば以下はIPv6でデフォルトルートの設定例です。

ipv6 route ::/0 FastEthernet1/0 fe80::0001


::/0はIPv6でデフォルトルートを意味します。IPv4ではあまり見られない項目として物理インターフェイスを指定しています。これはリンクローカルアドレスは必ずユニークであるというものではなく、セグメントが異なれば重複することも認められているものです。そのためIPアドレスだけを指定したのでは重複があった場合にはどこに投げれば良いか判断がつかないケースがあるため、物理インターフェイスを合わせて指定するよう奨励されています。


■EIGRPv6の設定

EIGRPのIPv6対応バージョンがEIGRP for IPv6です。Cisco社が開発したプロトコルであり「RIPよりもスケーラビリティがあり、OSPFよりも容易に理解できるように」というコンセプトで開発されました。

EIGRPv6とEIGRPv4の間には以下のような共通点があります。

○経路選択アルゴリズムとしてDUALを使用する
○ルータIDの指定はIPv4アドレス表記を使用

EIGRPv4からの主な変更点は以下のとおりです。

○IPv6をトランスポートに使用する
○IPv6経路情報をアドバタイズする
○IPv4の経路情報は受け取らない
○各種アップデータパケット等は送信元アドレスにリンクローカルアドレスを使用する
○送信元アドレスにはFF02::Aを使用する

EIGRPv6の設定を見てみます。以下の構成図を前提にします。R1はスタティックでデフォルトルートを設定しており、それをEIGRP経由でR2に配信しています。



このときのR1の設定は以下のようになります。router-idの部分でIPv4アドレスを使用しています。これは例えIPv4アドレスを使用していないとしてもこれだけはIPv4を使用する必要があります。

[R1の設定]

ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:0:1::1/64
 ipv6 eigrp 170
!
interface FastEthernet0/1
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:0:254::1/64

ipv6 route ::/0 2001:DB8:0:254::254
ipv6 router eigrp 170
 router-id 1.1.1.1
 no shutdown
 redistribute static

R2は以下のような設定となります。

[R2の設定]

ipv6 unicast-routing
ipv6 cef

interface Loopback0
 ipv6 address 2001:DB8:0:2::1/64
 ipv6 eigrp 170
!
interface FastEthernet0/0
 ipv6 address FE80::2 link-local
 ipv6 address 2001:DB8:0:1::2/64
 ipv6 eigrp 170

ipv6 router eigrp 170
 router-id 2.2.2.2
 no shutdown

ルーティングテーブルがどうなっているか見てみましょう。まずR1です。OSPFv3経由でR2のLoアドレスに対する経路が受信できていることが確認できます。合わせてネクストホップアドレスがリンクローカルアドレスであることも確認できます。

R1# show ipv6 route eigrp
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   2001:DB8:0:2::/64 [90/409600]
     via FE80::2, FastEthernet0/0

次にR2です。こちらはR1から配信されているDefaultRouteを受信できていることが確認できます。また、こちらもネクストホップはリンクローカルアドレスであることがわかります。

R2# show ipv6 route eigrp
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
EX  ::/0 [170/281600]
     via FE80::1, FastEthernet0/0

R2から見たEIGRPのネイバーは下記のようになります。

R2# show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 170
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Fa0/0             13 00:02:07 1282  5000  0  3
    FE80::1




 
 関連記事
 IPv6の概要
 IPv6の挙動
 IPv6の基本設定
 IPv6のルーティング ( OSPFv3 )の設定
 IPv6のルーティング ( EIGRPv6 )の設定
 IPv6のルーティング ( MP-BGP )の設定
  IPv6のマルチキャストルーティングの設定
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.