UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - Catalyst STP ( Spanning Tree Protocol ) の基本設定




■PVST+の基本設定


CatalystではSTPの設定はPVST+ ( Per Vlan Spanning Tree Plus ) と呼ばれます。これはVLANごとに個別のSTPインスタンスを保持するというものです。Catalystではデフォルトで全てのVLANでSTPが有効 になっており個々の VLANで1つのSTPが実行されますので各VLANでルートブリッジが存在するということになります。また、CatalystではVLAN単位でSTP の有効/無効を設定することが可能です。


デフォルトで有効になっているSTPを無効にする場合は以下のコマンドを実施します。


(config)# no spanning-tree vlan XX

PVSTを設定する際は何もしなくとも接続 すれば一応機能はするものの最低限ルートブリッジの選定ぐらいは誰しもが手動でやっていると思います。その際のコマンドが以下となります。VLAN単位で STPが稼働するのでVLANごとに設定可能です。プライオリティに指定できる値は0~32768の間で4096の倍数になります。値が低いほうが優先さ れますのでルートブリッジに指定したいスイッチには0を指定することになります。


(config)# spanning-tree vlan XX priority 0


物理ポートにプライオリティを設定することも可能で以下のコマンドで実施します。デフォルト値は128であり、これについては0~240の間で16の倍数 である必要があります。AccessポートかTrunkポートかで設定の違いがあり、Trunkの場合はVLANも合わせて設定することになります。


(config)# interface GigabitEthernet0/1
(config-if)# switchport access vlan 100
(config-if)# switchport mode access
(config-if)# spanning-tree port-priority 128

(config)# interface GigabitEthernet0/2
(config-if)# switchport trunk allowed vlan 100
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 100 port-priority 128


ルートブリッジまでのルートを決める際に主な指標となるのがポートコストです。帯域幅によって自動設定されますが、任意に変更することも可能であり、その 場合のコマンド が下記となります。こちらもポートプライオリティと同様にTrunkかAccessかで設定に違いがでてきます。


(config)# interface GigabitEthernet0/1
(config-if)# switchport access vlan 100
(config-if)# switchport mode access
(config-if)# spanning-tree cost 10

(config)# interface GigabitEthernet0/2
(config-if)# switchport trunk allowed vlan 100
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 100 cost 10


■showコマンド


STPを設定した際に確認するコマンドはshow spanning-treeコマンドです。以下、VLAN XXのルートブリッジにおける出力の一例です。


# show spanning-tree

VLAN00XX
Spanning tree enabled protocol ieee
 # ルートブリッジ情報
 # Priorityの値はVLAN ID + Priority値
Root ID Priority XX
Address xxxx.yyy.xxxx
 # 自身がルートブリッジの場合は下記のように表示される
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

 # 自身のブリッジ情報、自身がルートブリッジであれば上記と同一になる
Bridge ID Priority XX (priority 0 sys-id-ext XX)
Address xxxx.yyyy.xxxx
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

# RoleはDesg=指定ポート、Altn=非指定ポート、Root=ルートポート
# StsはFWD=転送状態、BLK=ブロック状態
# Costはポートパスコスト、Prio.Nbrはポートプライオリティ.ポート番号で構成
# Typeはスイッチ間が直接接続なら「P2P」、Portfastの場合は「Edge P2p」
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/X Desg FWD 19 128.X P2p
Gi1/0/Y Desg FWD 4 128.Y P2p
Gi1/0/Z Altn BLK 4 128.Z P2p



 関連記事
 VLAN操作
 PrivateVLANの設定
 EtherChannelの設定
 StormControlの設定
 DHCP Snoopingの設定
 Catalyst QoSの設定
 SpanningTreeProtocolの 設定
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.