UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Linux - CentOS NIC Bonding




■NIC Teaming設定


Linuxの物理NICを複数束ねて論理的に1本にすることができます。一般的にBondingと呼ばれます。具体的な設定は以下となります。


# vi /etc/modeprobe.d/bonding.conf
alias bond0 bonding
options bond0 mode=4 miimon=100


optionsで指定出来る項目は上記以外にも多数存在しています。こちらのサイトが参考になります。

上記のmode=4ではLACP(IEEE803.AD)を利用したbondingとなります。当然接続するスイッチ側もLACPに対応してないといけな いということになります。個人的にはmodeの指定は常にLACPで設定しています。これでうまくいかなかったことは未だにない。各物理NICの設定を以下に示します。


# vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE="eth0"
USERCTL=none
BOOTPROTO=none
ONBOOT="yes"
MASTER=bond0
SLAVE=yes


# vi /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE="eth1"
USERCTL=none
BOOTPROTO=none
ONBOOT="yes"
MASTER=bond0
SLAVE=yes

# vi /etc/sysconfig/network-scripts/ifcfg-bond0

DEVICE="bond0"
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
IPADDR=192.168.XX.XX
NETMASK=255.255.255.0
BROADCAST=192.168.XX.YY
NETWORK=192.168.XX.ZZ

# /etc/rc.d/init.d/network restart


スイッチ側の設定もLACPで設定する必要があります。Cisco社製、Catalystスイッチの場合、以下の ようになります。


interface GigabitEthernet 0/1
switchport access vlan xxx
switchport mode access
channel-group 1 mode active

interface GigabitEthernet 0/2
switchport access vlan xxx
switchport mode access
channel-group 1 mode active

interface Port-Channel1
switchport access vlan xxx
switchport mode access



■ステータス確認


Linux側では/proc/net/bonding/bond0を閲覧することでステータスを確認できます。


# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 5000
Down Delay (ms): 0

802.3ad info
LACP rate: slow
Aggregator selection policy (ad_select): stable
Active Aggregator Info:
Aggregator ID: 1
Number of ports: 2
Actor Key: 17
Partner Key: 3
Partner Mac Address: 00:12:e2:a2:f5:2a

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 34:40:b5:86:13:88
Aggregator ID: 1
Slave queue ID: 0

Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: 34:40:b5:86:13:89
Aggregator ID: 1
Slave queue ID: 0


スイッチ側では以下のコマンドで確認できます。


# show lacp 1 neighbor
# show lacp 1 internal
# show etherchannel summuary



 
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.