UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - Catalyst RSTP ( Rapid Spanning Tree Protocol )の設定



■RSTPの基本設定


RSTP ( Rapid Spanning Tree Protocol ) はSTPの改良版でありSTPのトポロジー変化による収束時間を大幅に短縮します。
基本的な考え方はSTPとほぼ同じですがポートの種類がRSTPのほうが増えています。RSTPで使用するポートの種 類は以下。


ポートの種類  説明  トラフィックの可否 
ルート ( Root ) ポート  各スイッチからルートブリッジに最も近いポート  可 
指定 ( Designated ) ポート  各セグメントからルートブリッジに最も近いポート  可 
代替 ( Alternate ) ポート  ルートポートのバックアップ  否 
バックアップ ( Backup ) ポート  指定ポートのバックアップ  否 


STPと比較してブロックポートがバックアップポートに該当し、新たに代替えポートという概念がRSTPには存在します。ルートポートおよび指定ポートが フレームを転送するポートであり、代替ポートとバックアップポートはフレームを転送しません。STPの場合だとRootブリッジの ポートはすべて指定ポートとなりますが、RSTPでは指定ポートもしくはバックアップポートになります。ま たポートの状態としてSTPとして合わせて記載すると以下のようになります。


STPポートステータス RSTPポートステータス トポロジーに含まれているか? Macアドレスを学習しているか?
Blocking Discarding No No
Listening Discarding No No
Learning learning No Yes
Forwarding Fowarding Yes Yes


RSTPの設定の際には以下のように設定します。


(config)# spanning-tree mode rapid-pvst


その他、コストやプライオリティの設定はSTPと同様です。STPとほぼ同じ設定でありながら高速収束するのでSTPで要件を満たせるならRSTPを選択 しない理由はないと思いますがSTPではなくRSTPにしておいて良かった、と経験したことはいまだありません。気休め程度だと思っておいたほうが良いで しょう。


■RSTPによるトラフィックロードバランス


スイッチ同士の接続を冗長化したい場合、最も簡単な方 法はEtherChannelです。ただし、何らかの事情、例えば広域イーサ越しに冗長化を行いたい場合 などは広域イーサがEtherChannelに対応していなければ設定することが出来ません。そういった場合、別な手法としてRSTPでVLAN単位でト ラフィックをロードバランスかつ冗長化を行うことが可能です。以下の図を前提として設定例を紹介します。



この場合においても広域イーサの中でBPDUが透過することが前提となります。各L2スイッチのGi1/0/1でVLAN10, 20, 30を流し、Gi1/0/2でVLAN40, 50を流すように設定します。


※L2スイッチAの場合
VLAN10, 20, 30においてL2スイッチAのGi1/0/1は指定ポートになり、Gi1/0/2はバックアップポートになります。VLAN40, 50においてL2スイッチAのGi1/0/1はバックアップポートになり、Gi1/0/2は指定ポートになります。


※L2スイッチBの場合
VLAN10, 20, 30においてL2スイッチBのGi1/0/1はルートポートになり、Gi1/0/2は代替ポートになります。VLAN40, 50においてL2スイッチBのGi1/0/1は代替ポートになり、Gi1/0/2はルートポートになります。


L2スイッチAの設定は以下のようになります。


(config)# vlan 10,20,30,40,50

(config)# spanning-tree mode rapid-pvst
(config)# spanning-tree vlan 10,20,30,40,50 priority0

(config)# interface GigabitEthernet1/0/1
(config-if)# switchport trunk allowed vlan 10,20,30,40,50
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 10,20,30 port-priority 112

(config)# interface GigabitEthernet1/0/2
(config-if)# switchport trunk allowed vlan 10,20,30,40,50
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 40,50 port-priority 112


L2スイッチBの設定は以下のようになります。


(config)# vlan 10,20,30,40,50

(config)# spanning-tree mode rapid-pvst

(config)# interface GigabitEthernet1/0/1
(config-if)# switchport trunk allowed vlan 10,20,30,40,50
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 10,20,30 cost 1

(config)# interface GigabitEthernet1/0/2
(config-if)# switchport trunk allowed vlan 10,20,30,40,50
(config-if)# switchport mode trunk
(config-if)# spanning-tree vlan 40,50 cost 1


ルートブリッジにおいて指定ポートかバックアップポートかを選択する基準はポートプライオリティになります。ルートブリッジにおいてパスコストを 調整してもそれは意味がありませんので注意してください。逆に
非ルートブリッジにおいてルートポートか代替えポートかを選択する基準はポートパスコストになります。


L2スイッチAのVLAN10と40のステータスは以下のようになります。


# show spanning-tree vlan 10

<省略>

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Desg FWD 4 112.1281 P2p
Gi1/0/2 Back BLK 4 128.1282 P2p



# show spanning-tree vlan 40

<省略>

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Back BLK 4 128.1282 P2p
Gi1/0/2 Desg FWD 4 112.1281 P2p


L2スイッチBのVLAN10と40のステータスは以下のようになります。


# show spanning-tree vlan 10

<省略>

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Root FWD 1 128.1281 P2p
Gi1/0/2 Altn BLK 4 128.1282 P2p



# show spanning-tree vlan 40

<省略>

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Altn BLK 4 128.1281 P2p
Gi1/0/2 Root FWD 1 128.1282 P2p


以上のようにRSTPではポートプライオリティおよびコストでロードバランスおよび冗長化を実現することができます。ただし、EtherChannel. が組める場合はそれにしたほうが構成的にもシンプルなのでそちらにしたほうがベターだと思います。



 関連記事
 VLAN操作
 PrivateVLANの設定
 EtherChannelの設定
 StormControlの設定
 DHCP Snoopingの設定
 Catalyst QoSの設定
 SpanningTreeProtocolの 設定
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.