UnixPower on Networking
  http://www.unix-power.net/

 
 Top - Cisco - IPv6のルーティング(OSPFv3)設定




■IPv6ルーティング

IPv6のルーティングに関してIPv4と比較して大きな変化はありません。IPv4でルーティングプロトコルを設計・運用していたかたなら、そこで培ったノウハウをIPv6でもすぐに発揮することができます。個々のIPv6ルーティングについても各々のコンセプトは従来のIPv4にIPv6拡張機能を追加したという意味合いが強くルーティングアルゴリズムに大きな変更が加えられたものではありません。

以下がIPv4とIPv6のルーティングプロトコルの対応表です。

名称  IPv4  IPv6 
Static Routing
Default Route  ○  ○ 
Unicast IGP
RIP  RIPv1  × 
  RIPv2  RIPng 
OSPF OSPFv2  OSPFv3 
IGRP  IGRP  × 
EIGRP  EIGRP  EIGRPv6 
ISIS ISIS  ISISv6 
Unicast EGP
BGP  BGP  MP-BGP ( BGP4+ )
Multicast
PIM  PIM  PIM 


ルーティングプロトコルでやりとりをするアドレスはリンクローカルアドレスでした。スタティックルーティングにおいてネクストホップアドレスを指定する際はグローバルユニキャストアドレスではなくリンクローカルアドレスを指定することになります。例えば以下はIPv6でデフォルトルートの設定例です。

ipv6 route ::/0 FastEthernet1/0 fe80::0001


::/0はIPv6でデフォルトルートを意味します。IPv4ではあまり見られない項目として物理インターフェイスを指定しています。これはリンクローカルアドレスは必ずユニークであるというものではなく、セグメントが異なれば重複することも認められているものです。そのためIPアドレスだけを指定したのでは重複があった場合にはどこに投げれば良いか判断がつかないケースがあるため、物理インターフェイスを合わせて指定するよう奨励されています。


■OSPFv3の設定

日本国内で最も多く使われているダイナミックルーティングプロトコルはOSPFではないでしょうか。上に書いたようにIPv6のOSPFはOSPFv6です。この設定方法を記載致します。まずネットワーク構成は以下を前提とし、R1とR2でOSPFv3のネイバーをはるという構成です。R1ではDefaultRouterをStaticで設定しそれをOSPFv3経由でR2に配信しています。R2からはLoアドレスをOSPFv3経由で受け取ります。



このときのR1の設定は以下のようになります。router-idの部分でIPv4アドレスを使用しています。これは例えIPv4アドレスを使用していないとしてもこれだけはIPv4を使用する必要があります。

[R1の設定]

ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:0:1::1/64
 ipv6 ospf 110 area 0.0.0.0
!
interface FastEthernet0/1
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:0:254::1/64

ipv6 route ::/0 2001:DB8:0:254::254
ipv6 router ospf 110
 router-id 1.1.1.1
 log-adjacency-changes
 default-information originate

R2は以下のような設定となります。

[R2の設定]

ipv6 unicast-routing
ipv6 cef

interface Loopback0
 ipv6 address 2001:DB8:0:2::1/65
 ipv6 ospf 110 area 0.0.0.0
!
interface FastEthernet0/0
 ipv6 address FE80::2 link-local
 ipv6 address 2001:DB8:0:1::2/64
 ipv6 ospf 110 area 0.0.0.0

ipv6 router ospf 110
 router-id 2.2.2.2
 log-adjacency-changes

ルーティングテーブルがどうなっているか見てみましょう。まずR1です。OSPFv3経由でR2のLoアドレスに対する経路が受信できていることが確認できます。合わせてネクストホップアドレスがリンクローカルアドレスであることも確認できます。

R1# show ipv6 route ospf
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
O   2001:DB8:0:2::1/128 [110/10]
     via FE80::2, FastEthernet0/0

次にR2です。こちらはR1から配信されているDefaultRouteを受信できていることが確認できます。また、こちらもネクストホップはリンクローカルアドレスであることがわかります。

R2# show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OE2  ::/0 [110/1], tag 110
     via FE80::1, FastEthernet0/0




 
 関連記事
 IPv6の概要
 IPv6の挙動
 IPv6の基本設定
 IPv6のルーティング ( OSPFv3 )の設定
 IPv6のルーティング ( EIGRPv6 )の設定
 IPv6のルーティング ( MP-BGP )の設定
  IPv6のマルチキャストルーティングの設定
 Copyright(C) 2003-2015 UnixPower on Networking All rights reserved.